log in

Warning: do not upgrade beyond VirtualBox 4.3.12 !!


Advanced search

Message boards : News : Warning: do not upgrade beyond VirtualBox 4.3.12 !!

1 · 2 · 3 · 4 . . . 10 · Next
Author Message
Profile Ben Segal
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 1 Nov 10
Posts: 1205
Credit: 264
RAC: 0
Message 16949 - Posted: 17 Jul 2014, 12:20:25 UTC

Due to several problems being reported with the latest version of VirtualBox (4.3.14), we strongly advise volunteers not to upgrade beyond VirtualBox 4.3.12.

The team

Profile Ex_Brit
Avatar
Send message
Joined: 21 Feb 11
Posts: 166
Credit: 134,252
RAC: 0
Message 16956 - Posted: 17 Jul 2014, 22:42:26 UTC - in response to Message 16949.

Thanks for the warning. ;-)

Profile MAGIC Quantum Mechanic
Avatar
Send message
Joined: 1 Mar 11
Posts: 708
Credit: 9,025,574
RAC: 6,954
Message 16958 - Posted: 17 Jul 2014, 23:53:37 UTC

All 6 of my hosts (#7 is under repair) have completed 3 tasks in a row with no problems with our new version.

I am watching one right now (my only Win8.1 OS) and the only difference I see is the task will be 24hrs 13mins 23secs

I never update Boinc or VB to the newest versions until they have been running for several months so I never have that problem either.

Only thing that I changed this year was adding the extension pack.

And on the Win8.1 I also have 3 Atlas running along with the Theory Simulations v260.79 (vbox64) (and 3 Einstein GPU tasks) on a quad core

(with XP Pro,Win7,and Win8.1 OS)



Older VB downloads <---
____________

Profile david9000
Avatar
Send message
Joined: 29 Jan 12
Posts: 9
Credit: 333,931
RAC: 141
Message 16966 - Posted: 19 Jul 2014, 0:16:27 UTC

As I read this thread I realize I am still merrily using Virtualbox 4.3.8.
Am I missing out on the latest and greatest? In this case, 4.3.12?

Profile MAGIC Quantum Mechanic
Avatar
Send message
Joined: 1 Mar 11
Posts: 708
Credit: 9,025,574
RAC: 6,954
Message 16970 - Posted: 19 Jul 2014, 3:05:18 UTC - in response to Message 16966.

I still had the even older 4.2.16 version running here with no problem but just did the update to 4.3.12 to see if it would run Atlas too.......I had to do that with another host to get it to run both Atlas X3 along with the new version of T4T
____________

Profile david9000
Avatar
Send message
Joined: 29 Jan 12
Posts: 9
Credit: 333,931
RAC: 141
Message 16975 - Posted: 19 Jul 2014, 8:00:40 UTC

Thanks, and fantastic! I did not know about Atlas@home. Practically brand new:
http://atlasathome.cern.ch/forum_index.php

For me, it'll have to wait until I get a machine worthy.

Profile Ex_Brit
Avatar
Send message
Joined: 21 Feb 11
Posts: 166
Credit: 134,252
RAC: 0
Message 16979 - Posted: 19 Jul 2014, 15:40:58 UTC - in response to Message 16975.

Thanks, and fantastic! I did not know about Atlas@home. Practically brand new:
http://atlasathome.cern.ch/forum_index.php

For me, it'll have to wait until I get a machine worthy.


Me too. I noted that they haven't yet opened up all Teams in their list, should anyone be considering adding them to BOINC.

Profile Ex_Brit
Avatar
Send message
Joined: 21 Feb 11
Posts: 166
Credit: 134,252
RAC: 0
Message 16980 - Posted: 19 Jul 2014, 15:42:16 UTC - in response to Message 16979.
Last modified: 19 Jul 2014, 15:42:23 UTC

Back to the original subject. I assume you'll give us the all clear when 4.3.14 becomes usable?

Jacob Klein
Send message
Joined: 26 Jul 13
Posts: 111
Credit: 128,473
RAC: 0
Message 16999 - Posted: 21 Jul 2014, 16:44:08 UTC
Last modified: 21 Jul 2014, 17:19:14 UTC

4.3.12 is the recommended version, and should work fine for all BOINC VM projects, per my experience. Stick with 4.3.12 for now. Seriously. [And if you're using a lower version, you really should upgrade to 4.3.12]

4.3.14 has a few crippling issues... that possibly only exist on Windows. This version cripples BOINC VM tasks (which will require new app versions that utilize 26095 or higher of the VBoxWrapper, and even then, would offer no support for lowering the priority of running VM tasks), and also cripples simply getting VMs to work without interference from antivirus utilities and other utilities that happen to make use of .dll injection.

4.3.16 is in development, but it is unknown whether Oracle will decide to rollback the "hardening" features that crippled 4.3.14, or if they'll attempt to develop some sort of "white-list". Their choice could also affect whether BOINC VM apps require the new VBoxWrapper or not. It's still a work in progress, and so we just have to wait on Oracle to develop/release it. [Maybe we'll get more than 4 days to test a Release Candidate, grrrr, and not ignore the complaints before shipping].

Again, stick with 4.3.12 for now.

For additional information, you can go to the Oracle Virtualbox forums, and read up about the issues.
https://forums.virtualbox.org/
https://forums.virtualbox.org/viewtopic.php?f=25&t=62618
https://forums.virtualbox.org/viewtopic.php?f=6&t=62615

Profile Ex_Brit
Avatar
Send message
Joined: 21 Feb 11
Posts: 166
Credit: 134,252
RAC: 0
Message 17017 - Posted: 23 Jul 2014, 17:36:31 UTC - in response to Message 16999.

I've noticed recently that Vbox is/was eating a great deal of my RAM (9 out of 12gb) so have discontinued using it until I troubleshoot as it was slowing my machine down. Now I'm not necessarily blaming vLHC as I recently added ATLAS to the BOINC client and it also use Vbox.
Sorry for aborting tasks but was really busy with other duties and it was driving me insane that every right-click (for one example) was taking too long to execute. Now everything is back to normal.
Comments on that little revelation? (It is 4.3.12 btw).

Profile rbpeake
Send message
Joined: 24 May 11
Posts: 174
Credit: 2,005,641
RAC: 1,047
Message 17019 - Posted: 23 Jul 2014, 18:53:25 UTC - in response to Message 17017.
Last modified: 23 Jul 2014, 18:54:27 UTC

I believe Atlas takes over 1gb for each instance. You did not say how many instances you are running, but I had to add RAM to 16 to smoothly run 4 Atlas on my work computer.

Profile tullio
Send message
Joined: 28 Nov 10
Posts: 1556
Credit: 1,516,155
RAC: 331
Message 17020 - Posted: 23 Jul 2014, 18:56:02 UTC - in response to Message 17017.
Last modified: 23 Jul 2014, 18:56:56 UTC

I am running three Virtual Machines, vLHC, Solaris and Ubuntu on my Linux host with 8 GB RAM and it's never using it all. vLHC uses very little RAM, I was running it on my Ubuntu Virtual Machine with only 1 GB RAM, while Solaris uses 2 GB RAM. All this on SuSE Linux 13.1. Recently the new server would send me no more units to the Ubuntu because it has only a 8 GB virtual hard disk, so I installed climateprediction.net on it.
Tullio

Profile Ex_Brit
Avatar
Send message
Joined: 21 Feb 11
Posts: 166
Credit: 134,252
RAC: 0
Message 17022 - Posted: 23 Jul 2014, 19:12:17 UTC - in response to Message 17019.

I believe Atlas takes over 1gb for each instance. You did not say how many instances you are running, but I had to add RAM to 16 to smoothly run 4 Atlas on my work computer.


There were 6 installed and 4 instances running. So it was as I thought, ATLAS that was bogging things down Will have to pursue that with them.

Thanks

Profile Diego Manalastas
Send message
Joined: 5 Aug 14
Posts: 1
Credit: 0
RAC: 0
Message 17072 - Posted: 5 Aug 2014, 12:06:05 UTC

I recently signed up for this project, and only saw this warning now. Is there any way to downgrade my VB 4.3.14?

Jacob Klein
Send message
Joined: 26 Jul 13
Posts: 111
Credit: 128,473
RAC: 0
Message 17074 - Posted: 5 Aug 2014, 13:18:55 UTC - in response to Message 17072.
Last modified: 5 Aug 2014, 13:19:09 UTC

I recently signed up for this project, and only saw this warning now. Is there any way to downgrade my VB 4.3.14?


Close BOINC, uninstall VirtualBox 4.3.14, install VirtualBox 4.3.12, run BOINC. You may lose tasks that had already started, but that's okay, because you really do want to stay away from 4.3.14 (especially if you are using Windows).

Crystal Pellet
Volunteer moderator
Avatar
Send message
Joined: 5 Aug 11
Posts: 1606
Credit: 1,443,237
RAC: 309
Message 17075 - Posted: 5 Aug 2014, 14:46:47 UTC - in response to Message 17074.
Last modified: 5 Aug 2014, 17:36:36 UTC

I recently signed up for this project, and only saw this warning now. Is there any way to downgrade my VB 4.3.14?


Close BOINC, uninstall VirtualBox 4.3.14, install VirtualBox 4.3.12, run BOINC. You may lose tasks that had already started, but that's okay, because you really do want to stay away from 4.3.14 (especially if you are using Windows).

You may find version 4.3.12 for your Windows machine here: http://download.virtualbox.org/virtualbox/4.3.12/VirtualBox-4.3.12-93733-Win.exe

and the compatible extension pack here: http://download.virtualbox.org/virtualbox/4.3.12/Oracle_VM_VirtualBox_Extension_Pack-4.3.12-93733.vbox-extpack

Jacob Klein
Send message
Joined: 26 Jul 13
Posts: 111
Credit: 128,473
RAC: 0
Message 17076 - Posted: 5 Aug 2014, 17:04:28 UTC

To make it a bit more general... You may find older builds of VirtualBox and the Extension Pack, by following these steps:

- Go to http://www.virtualbox.org
- Click "Downloads"
- Click "VirtualBox older builds"

For the BOINC community, on Windows, 4.3.12 is what is currently recommended.

keputnam
Send message
Joined: 13 Oct 11
Posts: 65
Credit: 423,317
RAC: 620
Message 17077 - Posted: 5 Aug 2014, 17:49:44 UTC
Last modified: 5 Aug 2014, 17:53:06 UTC

On the Berkeley BOINC download page, the combined BOINC and VBox now contains 4.2.16


Has that version been tested with vLHC?


Update:

Never mind You are talking about 4.*3*.12 Duh!

Profile MAGIC Quantum Mechanic
Avatar
Send message
Joined: 1 Mar 11
Posts: 708
Credit: 9,025,574
RAC: 6,954
Message 17078 - Posted: 5 Aug 2014, 20:44:28 UTC

http://lhcathome2.cern.ch/vLHCathome/forum_thread.php?id=1508&postid=16958
____________

Profile tullio
Send message
Joined: 28 Nov 10
Posts: 1556
Credit: 1,516,155
RAC: 331
Message 17083 - Posted: 6 Aug 2014, 13:52:18 UTC

I think I am running Virtual Box 4.3.13 on my new HP PC with Windows 8 installed in factory, Running Atlas@home on a 64 bit CPU AMD A10-6700 at 3.7 GHz All well, but both wireless keyboard and mouse do not work. I had to lease USB cables from this venerable host.
Tullio

1 · 2 · 3 · 4 . . . 10 · Next

Message boards : News : Warning: do not upgrade beyond VirtualBox 4.3.12 !!